Aweber integration

August 20, 2010

in Training

Integrate the optincrusher web form with your Aweber email service to maximize the number of optins you get on your website. Build an email list in WordPress.

{ 66 comments… read them below or add one }

Sue October 14, 2010 at 1:47 pm

Hi Daniel,
Thank you for OptIn Crusher! I am just learning about internet marketing and html code, and I must say, your plugin is easy to install, your tutorials are very helpful, and the whole look and feel of the plugin is great!

I just wanted to add that you might point out to people that the email webform from the third party email marketing service should be a simple name and email address form, without any graphics. I first tried to install a graphics based email opt in form from AWeber into OptinCrusher and it didn’t work — I was seeing only part of my graphic (the arrows) and not the boxes for name and email address. It wasn’t clear to me at first that the webform I needed to use was the simplest one – with the transparent background. But once I tried that form, it worked great! “Easy peasy lemon squeezy,” as Ed Dale would say!

Reply

Ira November 16, 2010 at 11:53 am

I’ve tried several forms offered by Aweber, to no avail. The name and email address fields simply don’t show up on the banner across the footer. I see “Name ” but nothing else.

Please advise!

Reply

Daniel November 16, 2010 at 12:05 pm

It looks like your theme might have form fields set to display block, which would show them on separate lines (they’re getting pushed down). You can see them in the lightbox, so I know they’re there. You’ll have to go in and fiddle with the styles for these fields to get then to display properly.

Reply

Ira November 17, 2010 at 8:46 am

Thanks! Didn’t occur to me to try a different theme. Good thing I didn’t like that theme anyway.

I tell you, sometimes this stuff makes me so angry! πŸ˜‰

Reply

Mark December 29, 2010 at 2:09 am

Hey Daniel,
It looks like my thyme is pushing my email and first name box down as well. I am using iContact though…. Don’t think that makes a difference, but just in case.
I don’t want to be so quick to change my thyme. you said to fiddle with the styles of the fields.. Are you talking about with my wordpress fields, thyme fields or the optin fields?
Also in some videos you have “WP Opt-In Crusher” under the settings tab, and in this video its under “optincrusher”
I have “optinecrusher” on my settings tab. So can i get the iphone enable and disable link?
Thank You!!!
Mark

Reply

Daniel December 29, 2010 at 4:02 pm

Mark,

The idea is to get all the formatting out of the form and to use a non-image submit button. Things should line up when you do that.

You should be able to modify your theme to accommodate optincrusher. In my experience the majority already do support it since it uses standard header and footer hooks.

Reply

Mark December 30, 2010 at 3:23 pm

well i am using a non image submit button. just the standard icontact submit button >Free<
i even tried just a simple code of
so i am pretty sure its something with my thyme.
oh well. ill figure it out.
thanks!
mark

Marcos November 26, 2010 at 4:43 pm

I went through everything the video walks you through but it’s still not working from me. Any idea what it could be?

Reply

Daniel November 26, 2010 at 4:51 pm

Marcos,

You’ll have to give a little more information than that. Can you explain what’s not working?

Reply

Marcos November 26, 2010 at 5:22 pm

Well, I go through the process of copying the raw html from my aweber form, then pasting it in the box above the “process form” button. Then I click the process form button and check my site to see if the optincrusher pops up but it never does. I’ve clicked yes for show if logged in to see if that was it. I just don’t know how to fix it.

Reply

Daniel November 26, 2010 at 9:59 pm

After you process the form you have to then click the save settings button. You also need to make sure that it is set to show for logged in users.

I just looked at your site and found another item that it isn’t rendering the footer portion of the code. I have a troubleshooter to help you through it.

http://helpdesk.danielwatrous.com/index.php?_m=troubleshooter&_a=steps&troubleshootercatid=1&parentid=0

Reply

Marcos November 26, 2010 at 11:54 pm

Ah, it worked! You’re awesome. I could kiss you!

Reply

Christopher December 27, 2010 at 6:11 pm

Thanks for the amazingly fast (and friendly) answers to my questions today. Your help in showing me where I’d gone wrong made getting this plugin working on my site in about three minutes.

Thank you!

Christopher

Reply

Cathy Keller December 28, 2010 at 10:32 am

I have had optincrusher successfully installed for a while now…it’s great! Yesterday, I decided I wanted to add a “first name” field to the form, which I did. I displays fine on the banner, but not on the “More Information” page. The two fields are butted together and the “email” label does not display. I have changed the form in aweber to a variety of different ones, changed the size…all to no avail. If I remove the “name” field, all is fine. Any suggestions would be appreciated! Thanks.

Reply

Daniel January 3, 2011 at 10:41 am

Hi Cathy,

When something like this happens on optincrusher, most of the problem comes from the WordPress theme you are using. Since you are using Headway as a theme, this issue occurs. Here’s a video that explains how to fix the issue: http://screencast.com/t/MKjIbYUhtaT

Reply

Cathy Keller December 28, 2010 at 6:21 pm

I forgot to mention that I’m using aweber. I must be doing something incorrect in processing the form because I hope to have it look just like yours. Thanks in advance for your help.

Reply

Paul January 9, 2011 at 3:21 pm

Hi there – I’m using a theme called WPRemix. I’m guessing it’s the issue, but I’m hoping you can help. I can’t get Optin Crusher to work properly. If it shows up at all, the Aweber opt-in form shows up at the top of the page and the OptinCrusher footer messes up my site’s footer and is just the green bar at the bottom with the icon. It doesn’t seem to load in 2 seconds either. My site is http://www.actusmr.com.

Reply

Daniel January 10, 2011 at 7:02 am

Paul,

It looks like you might have disabled it. You could certainly try the troubleshooter: http://helpdesk.danielwatrous.com/index.php?/Troubleshooter/Step/View/2

Reply

Velma January 19, 2011 at 8:20 am

I have installed it on http://welcomechangesradio.com, and everything looks great except for when I “click for details”. The form itself isn’t formatting properly. The instructions are really easy, so I’m not sure what I did wrong. I’m using Atahualpa for my them. I still need to update to 3.0.4. Could that be part of the problem? Thanks!

Velma

Reply

Daniel January 19, 2011 at 8:32 am

Hi Velma, the formatting looks OK for me. I’m using Google Chrome. What browser are you using?

Reply

Velma January 19, 2011 at 1:50 pm

Firefox. Checked IE, and it’s fine in there too. The Name is fine. The word Email is lined up near the Box for Name, and the box for the email drops to the next like…kind of like the Email line is indented, and there wasn’t enough room for it. (Hope that’s clear.) So it’s just Firefox giving me a bit of grief.

Thanks, Daniel. πŸ™‚

Velma

Reply

Diane January 19, 2011 at 3:51 pm

Hello!
I added the optincrusher and I love the appearance. I have it integrated with an aweber form. The issue I am having is that the optincrusher is not keeping my aweber setting to open in a new window. I don’t want the people opting in going away from my blog. I tested to see if this was an aweber issue and it is not. I looked through the code to see if I could isolate where the open in new window code was, but I can’t isolate it. Can you help with this issue?

Reply

Daniel January 19, 2011 at 9:26 pm

You probably want to use the raw HTML version and make sure that the javascript to load it in another window is present. That can be a bit tricky for sure and it would be difficult to explain it in a comment.

I would personally add a thank you confirm page on my site so that it submitted, but appeared to go directly to a page elsewhere on my site where I can tell them to confirm their optin. I typically also use a third page for a welcome message. Once they’re on your list you’ll have plenty of opportunity to get them back to your site πŸ™‚

Reply

Barry January 27, 2011 at 4:31 am

Hi.

I integrated Imnicamail into the slide up but in the pop up ‘click for details’ boxt, it has thrown out the styling for the opt in fields.

See here: http://www.barryrodgers.com
Any chance of taking a look at the ImnicaMail code and maybe suggesting what can be done to prevent this please?

Barry

Reply

Daniel January 27, 2011 at 7:01 am

Hi Barry, It should work fine with just about any email service since they all have to use and HTML form to collect user data. You might look for a good theme designer to help you with some of the formatting conflicts you see. They should be really quick to fix.

Reply

Barry January 27, 2011 at 2:25 pm

The error is appearing in the OptinCrusher pop up box (the one that appears when people click on the bottom left of the slide in) rather than in the theme.

[IMG]http://i51.tinypic.com/f2myj8.jpg[/IMG]

There appears to be no settings to edit for the autoresponder code in the pop up box So where do I find the pop up box in order to do something about this and how would I fix it?

Reply

Barry January 27, 2011 at 2:32 pm

Wait….silly me.

I just saw the fix. I simply had to adjust the font size in the opt-in details as it transfers into the lightbox.

Thanks for a great product. I have added this to my list and will review it on my blog this week

Reply

Stuart May 16, 2011 at 11:27 am

Well let me firstly saw I COULD NOT believe when I saw this plug in was free.

Daniel this plug in is fantastic and the support on your installation and configuration page is awesome too. I really have to say bravo to you for creating this plug in for wordpress. I managed to install and completely configure every part of it.

The only thing that I did have to do was take the form field size down from 16px to 15px due to my theme but once I did that, it was all good.

The site I have created and have this running on is http://www.saving-a-relationship.com but for my next project I will be created a blog about SEO and Internet Marketing. Within that I will be featuring software tools and plug in’s and this is #1 on my list and I would love to do a review about you too – if you want to get in touch you have my email. Great work again

Reply

Daniel May 16, 2011 at 11:30 am

Thanks Stuart!

Reply

Darrell December 30, 2011 at 9:11 am

Hi Daniel,
I’m having 2 problems: First, the name and email fields are not showing in the footer graphic. Secondly, the headline from the main form (in my right sidebar) is somehow being placed in the lightbox form area, where the name and email fields are not aligned correctly.

I’m using the Authoritize theme and I’m not sure how to adjust it if it is a theme issue. Any suggestions?

Thanks,
Darrell

Reply

Daniel January 3, 2012 at 10:09 am

Darrell, I’m sorry to hear that you’re having a hard time with the formatting. It might not all be related to your theme, but I wouldn’t rule that out.

The processing stage that’s built into the plugin attempts to strip out everything but the optin form and leave formatting to my plugin styles. Some changes by the email companies have made that less effective. You might need to go in and manually change image submit buttons to regular form submit buttons in order for them to look right.

Reply

Al-Yassa January 17, 2012 at 5:02 pm

Seems like my aweber code keeps getting stripped out. Once I put it in, update changes and log out…when I check my blog, optin crusher pops up but my optin area doesn’t show.

Reply

Daniel January 17, 2012 at 5:15 pm

I wonder if you’re pasting it into the top form and not clicking process form before updating. You need to the form to end up in the lower field before updating your settings.

Reply

Daniel January 17, 2012 at 5:16 pm

I just noticed that it shows up fine on sub pages, but not the home page. Maybe it has a conflict with the other optin form you already display there?

Reply

Al-Yassa January 17, 2012 at 5:44 pm

Thx for the speedy reply. I just scrolled thru all pages and it seems fine. Maybe it took my cache a bit of time to register browser changes. Oh well, thx again.

Reply

Ed Legaspi January 23, 2012 at 12:32 am

Hi Daniel

I’m not sure if you can help me here, but I’ll try anyway.

I installed your wp opt-in crusher plugin on my site, and it worked just fine. That was before I upgraded to WordPress 3.3.1 and/or FlexSqueeze Theme version 1.5.1. Now your plugin won’t work anymore no matter what I try.

For my aWeber form, I’m using the plain inline basic form with no graphics and showing only the fields for name and email. Can you help, please? Thanks.

All the best!
Ed Legaspi

Reply

Ed Legaspi January 23, 2012 at 3:51 am

Hi Daniel

Sorry about the previous post. I guess I was putting the proverbial “cart before the horse.”

After reading some of the other post, I went back to my site and discovered that following some of the options in your video tutorial when I installed the plugin, I clicked on the “Yes” option to “Hide from subscribed visitors” in the general settings. After trying again with the “No” setting, the plugin worked.

And I might like to add that your optincrusher plugin is just, in a word, FABULOUS!

All the best!

Ed Legaspi

Reply

Derek April 10, 2012 at 6:59 pm

Daniel,

We are using AWeber. After copying the form raw html code and pressing the “Process Form” button, all that shows up in the processed optin form is “”. Has AWeber changed their code or is there some reason the “Process Form” is not working?

Thanks,

Derek

Reply

Daniel April 10, 2012 at 8:10 pm

Derek,

You may have to manually integrate the form. Just strip out all the css and style information. Replace the image button with a regular submit input element. That’s the easiest way.

Reply

Derek K April 28, 2012 at 9:33 am

Daniel,
Like my namesake I had an issue with Aweber but during the design of the button I unchecked “Enable Facebook registration form” in step 2 on Awebers site. Voila! It works now.

Derek

Reply

reed July 15, 2012 at 1:55 am

Daniel,

I really love the optincrusher. Unfortunately I cannot get it to work with any of my Aweber forms.
No matter how simple a form I use from Aweber, still when I process the code in optincrusher, the resulting form on the lightbox is out of alignment. I read your threads and have tried to strip everything out the form but nothing seems to work.

I see I am not the first person to have this issue. Unfortunately I am not an HTML coder so I m not sure how to adjust the code after is has been processed by optincrusher to get it to realign.

Unlike the posts above, I never did have Facebook integration selected.

I would really appreciate your help because barring this issue this is the best optin form I have seen!

Thanks,

Reed Scott

Reply

Daniel July 16, 2012 at 10:08 pm

Reed, the easiest thing to do is remove the image submit button and replace it with a regular submit button. If you were really good at CSS you could probably make the image based button work.

Reply

Reed July 17, 2012 at 12:57 pm

Thanks Daniel.

I appreciate that. I have someone who is good at CSS that can probably fix that for me.

Reed

Reply

Paul January 23, 2013 at 9:06 am

Hi Daniel,

Great product but I am having problems with displaying the larger box when I click on the small bar. I copied my aweber code, no problem. It all appears great under Internet Explorer but the name and email fields are skewed and out of allignment on the larger box! Arrrrgh!! Any help you can give me with this would be greatly appreciate, thanks!! πŸ™‚

PS I tried clearing cookies in Firefox etc. no difference.

Reply

Paul Irvine March 28, 2013 at 6:28 pm

Hi Daniel,
This hidden gem is one of the best WP opt in plugins I’ve ever came across in my time online…still can’t believe that it’s free!

Thanks so much for sharing this with us all, I intend to let my subs know about it very soon so expect an onslaught of new users πŸ™‚

Paul.

Reply

Manuel June 6, 2013 at 4:08 pm

I have a problem. Once installed optincrusher, when I put the name and email and I click send, appears to be a petecion poup Underwriting in feedburner. I use Aweber. thank you very much

Reply

Daniel June 10, 2013 at 7:09 am

That’s strange. If you provided aweber code, that’s what should be used. I don’t include any feedburner code in my plugin. Is there a chance that you setup feedburner before and forgot to process your new aweber form?

Reply

DeMarus Perry July 20, 2013 at 12:04 pm

Hi Daniel, first off thank you for sharing this great plugin with the world! The problem I’m having is when I copy the HTML code into the box above the process form button, then press process form all I get in the bottom box is . When I clicked update all settings thats also all that showed up on the footer and the light box. I’m using Aweber now because I started with constant contact and I thought something was wrong…
Everything else seems to be working fine other than that… What am I missing?

Reply

Daniel July 20, 2013 at 5:23 pm

My hunch is that you’re pasting in a javascript form rather than an HTML form.

Reply

Robert Lockwood October 8, 2013 at 6:58 pm

Hi Daniel,

I am using Mail Chimp. Will you please provide me with integration instructions, similar to that of AWeber?

Thank you.

Robert

Reply

Daniel October 8, 2013 at 7:06 pm

Robert, they’re on the site. Just search for mailchimp in the search box.

Reply

Aayush Jindal October 11, 2013 at 5:42 am

Hello Daniel,

I have integrated the plugin on my Wordpress blog.

I have a coding issue.
I added a new field Mobile number and generated the code with “process form” as directed in the video.

There are two problems:

1. Mobile number text input filed was missing, only label was displayed. (I CORRECTED IT with myself, with some knowledge of code)

MY CURRENT Problem is that I want a value “+country code – mobile no,” to display in the mobile text box field.

I tried this code for it:-
Mobile:*

But it is not working.
Value is not displayed in the mobile text box.

Can you please help?

Regards,
Aayush

Reply

Aayush Jindal October 11, 2013 at 5:43 am

Sorry code cannot be added in the previous comment, trying again:-

Code I tried.

“”””Mobile:* “”””””

Reply

Aayush Jindal October 11, 2013 at 5:45 am

Sorry looks like code cannot be added.

Just to let you know I added changed value = “” to
value=”+country code – Mobile number”

But not working.

Please help.

Reply

Daniel October 11, 2013 at 7:05 am

You can show me the code using http://pastebin.com/

Are you trying to show a value inside the input field as a hint that they should type that into the input?

Reply

Aayush Jindal October 15, 2013 at 3:09 am

Yes Daniel,
I want to display a hint to users for mobile number to enter in right format.
“+country code – mobile number”

This is pastebin link for the code I am using – http://pastebin.com/bKX4hTTL

Please help me.

Rashid Rupani October 17, 2013 at 1:17 am

Hi Aayush,

Try this code:
http://codepad.org/40b7Q1Ax

and let me know your url?

Reply

Antonio January 24, 2014 at 4:04 pm

Hi Daniel!
I Just found out (a bit late judging by the date of the comments) about your awesome plugin and love it! I’ve been playing around with it and customized, so it looks sweet!
But I have a strange problem with the name and email fields not appearing correctly in the optin footer. They don’t show up as they should after I pasted my Aweber code.
You can see what i mean here:
http://vacationrentalsecrets.com/about/
Can you tell me how to fix that?
Thx!!!

Reply

Daniel January 24, 2014 at 4:18 pm

Antonio. It looks like all of the formatting didn’t get stripped out. Another possibility is that you have styles for your theme that cause form elements to appear on their own line.

Reply

Antonio January 24, 2014 at 10:50 pm

Thanks Daniel!
Do you know what I should do? Your plugin is so awesome, I wish I can srt this out!

Antonio

Reply

Rashid Rupani January 26, 2014 at 5:17 am

Hello Antanio, I have just checked your website and found some css issues that is why your aweber code is not appearing correctly. To fix this problem, please create a support ticket here http://helpdesk.danielwatrous.com/ so we can help you to fix this issue.

Reply

Theresa August 18, 2014 at 6:19 pm

I also am having a problem with Aweber Form integration – could you do an actual video of making the form – I did a great form for the site – but it showed way down – then I realized you cant do that – what kind of form would you make that would fit in that area! I’m stumped. I just used one that was already in the theme – not the theme. – its the Aweber Form – if you can find me a video on Youtube or somewhere showing how to make the form that integrates in there – that would be great.

Reply

Theresa August 18, 2014 at 6:22 pm

PS. I also got an error when I pasted the code and then trying to generate the form – all it showed was two arrows – no form? then I had to change permissions on my server – to get it to pass the code to the website – then I tried just pasting the code in without generating it – that seemed to work – a little weird but it seemed to work?

Reply

Daniel August 18, 2014 at 7:04 pm

I’m glad you got it working. The trick is to strip out all but the form and input elements. optincrusher will format those as needed for display.

Reply

Patricia (MustangOBM) August 27, 2014 at 7:00 am

Hi Daniel,

I love the OptinCrusher! This plugin was recommended to me and I have tried both with MailChimp and Aweber – I am unable to get the “Submit” button to show up? I am using the Theme Imprint PRO and I do use the Optimize Plugin with my theme as well.

I am at a loss on where to find the button or if it is “pushed” down I do not understand how to tweak the settings or where to go.

Thank you….
Patti πŸ™

Reply

Rashid Rupani August 27, 2014 at 10:42 pm

Hi Patricia,

Please create a support ticket so we can help you to fix this issue!

Reply

Leave a Comment

Previous post:

Next post: