Prevent youtube from covering optincrusher

August 23, 2010

in Integration

UPDATE: There’s a youtube plugin that makes integrating video easy and he’s just incorporated some changes that make this work correctly by default. You can learn more about the plugin here: http://www.artiss.co.uk/youtube-embed

Quite often it’s convenient (or necessary) to embed flash content within a WordPress post. This might include YouTube and other video players, audio players, advertisements, etc. However, when you have dynamic elements on your website that are built in layers, that pesky flash can show right on top of those layers.

Here’s a screenshot of what it looks like when it covers up the optin footer plugin for WordPress.

As it turns out there’s an easy way to fix the problem, and it only takes two lines of code. It does require you to modify the embed code that you get from YouTube, but after you’ve done it once or twice, you’ll find it doesn’t take more than 15 seconds.

Since this does require you to modify some HTML code, just follow the instructions exactly. You don’t need to understand what you’re doing. Just do follow the steps.

Solution

Here are the code snippets that you’ll need to paste:
<param name="wmode" value="transparent"></param>
wmode="transparent"

Full HD video training

{ 6 comments… read them below or add one }

mark December 5, 2010 at 8:51 am

Hi Daniel,
I found your solution for YouTube videos but still have the problem with self hosted videos using BitGravity as the player – any suggestions?
Mark.
P.S. The YT fix works perfectly, thanks.

Reply

Daniel December 6, 2010 at 8:41 am

Hi Mark,

bitgravity appears to use a javascript embed, which likely produces the embed code within a script. I suggest you email their support with a link to this post and ask them how to do the same thing for their embeds. They should be able to help you easily enough.

Reply

David December 29, 2011 at 10:53 pm

Hi Daniel,

Thanks for the video, unfortunately this won’t work as I am using a plugin called, Smart YouTube which doesn’t use that code, only the URL. Any ideas how I could get round this. Thanks David

Reply

Daniel January 3, 2012 at 10:06 am

I’m not sure about Smart YouTube, but I bet their support could answer that question. It might be as easy as adding the wmode parameter to the URL as ‘&wmode=transparent’

Reply

peter July 16, 2012 at 2:48 pm

Hi there, Im noticing that my header image and toolbar buttons go over top of the opt in footer and the same thing happens with the light box. Seems like a similar issue what can I do to fix this so that the opt in is on top of everything?

Thanks

Reply

Daniel July 16, 2012 at 10:11 pm

You need to change the z-index of either the optincrusher (higher) or the bar on the page (lower).

Reply

Leave a Comment

Previous post:

Next post: